Until next automatic change

Hello,

I have installed Tado devices last week. When I change the temperature on the thermostat itself, it does not follow the schedule anymore. I would like that the smart schedule is taking over control when a new event occurs of the smart schedule.

Settings

  • Living room - Manual control on tado device: Until next automatic change
  • Living room - Schedule: 08:00-16:00 @ 16 degrees, 16:00-22:00 @ 16 degrees, 22:00 - 08:00 @ 16 degrees.

Steps

  • At 18:00 I'm turning on the heating by adjusting the temperature manually on the tado thermostat
  • When I open the app afterwards and go to the living room, it does not mention that the temperature will be changed at 22:00 (according the smart schedule)
  • When I go to bed after 22:00 it is still heating my living room and I need to adjust the temperature manually back

Question:

  • Why is my tado not switching back when I manually changed the temperature on the thermostat device? If I change the temperature via the app, everything works as expected.


Thanks in advance for your prompt replies.

Best Answer

  • cbd20
    cbd20 ✭✭✭
    Answer ✓
    @SST Just a wild guess, but I wonder if the tado logic is flawed because you've got the same temperature set on all time blocks.

    Perhaps their logic isn't treating them as distinct time blocks as there's no temperature change from one block to the next?

    Try setting your 10pm onwards time block to say 15 degrees and see if it works correctly then. If it does, then that seems like a bug and should be reported back to them.

Answers

  • @SST Have you checked this?


  • SST
    SST

    @rafm5 Thanks for your quick reply.

    Yes, this setting is set to "Until next automatic change" with description "Any setting change on the tado device will remain active until the next time block in the Smart Schedule, or until residents leave or arrive.

    This implies to me that it will keep the temperature that is set manually until an event from the Smart Schedule occurs, but that doesn't happening in my case.

  • SST
    SST

    This is the state in the app.

    Normally the 'Untill next time block...' text is shown where a count down of the time is shown.


  • @SST What if you change your existing setup just to a 'whole day block' with 16 degrees?

  • SST
    SST

    @cbd20 Good one, I'll try that tonight and will come back with the result

    @rafm5 I've my doubts if that will work, if you have a whole day block, it might not generate a 'temperature change' event in the software? I'll try the suggestion from @cbd20 first, if this doesn't help, I'll try the whole day block.

  • SST
    SST

    @cbd20

    You're suggestion seems to work.

    I've changed my smart schedule plan as below:

    Then I set the temperature on the thermostat device to 17 degrees, the app is showing


    Now (13:30) the temperature setting has changed to 16.2 degrees (as per Schedule).

  • cbd20
    cbd20 ✭✭✭
    @SST Excellent.

    It might be worth reporting back to tado as clearly the interpretation of "next automatic change" doesn't work when two adjacent time blocks have the same set temperature.

    Although that being said, I suspect in reality that configuration is uncommon, so they likely wouldn't do anything, and perhaps might even say that the logic is valid to ignore a time point where the set temperature doesn't change.

    Either way, glad it's now working.
  • GrayDav4276
    GrayDav4276 ✭✭✭
    Hi @cbd20 & @SST
    You are both technically correct......we "presume" that Tado perceives the "Until next Automatic change" as a "Time Block" change......when in reality Tado is "looking" for a Temperature change. This is the reason that @cbd20's suggestion works.....I noticed this on my system a while ago.
    It's not a system operation "bug".....it's more a difference of "perception" of how we "think" our Tado system works.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!