Tado and HomeKit not syncing

Hi all,

Hope you can help me. I own a Tado smart thermostat for some time, always has been functioning normal, also in combination with HomeKit.
Since a few days I also started using a Tado smart temperature sensor to measure temperature in my office.
Also this combination was functioning properly for a day or two, but now the HomeKit app constantly shows a temperature of 21 degrees Celsius and constantly indicates my thermostat is in heating mode (both of which are wrong).Tado app is showing the actual temperature and heating status.
I deleted the Tado bridge and products from my HomeKit app, reinstalled them and it worked again, for 1 day, now the same problem started again.

Do you have any idea what is going wrong here?



  • rafm5
    rafm5 ✭✭✭

    @Kjuu Running iOS 15?

  • I'm having the same issue - on iOS 15.
  • rafm5
    rafm5 ✭✭✭

    @Vanna HomeApp is very buggy on iOS 15.

    iOS 15.2 (currently in beta) has resolved majority of issues, so as soon as available am GM get an update.

  • I have the same issue, iOS 15 and an iPad 15, my home is controlled by my Apple TV.

    My problems started after upgrading to iOS 15 It seems.

    After reconnecting the bridge and accessories to HomeKit it works for about a week, than HomeKit is stuck on 18c and heating to 20c, but according to the todo app its not. Changing setting is HomeKit will change the temperature but HomeKit keeps showing 18c and heating to 20c.

  • dennisb
    edited November 23
    After I got quite annoyed with this, I tried setting up tado through homebridge.io, which actually worked perfectly. This lets me to conclude there is some integration work with HomeKit to be done by Tado.

    I am not sure if the people of Tado monitor these threads, but would be good for the them acknowledge the problem and come with a solution.