System always heating whether CH and HW on or off

I've tried replacing the old CH & HW controller in my system with a Tado wireless receiver and wireless temperature sensor. The problem I have is that whenever the power to the system is on, the bolier runs regardless of whether the wireless temperature sensor or scheduled switching or manual overrides via the app are calling for heating and/or hot water or not. All the LEDs on the wireless receiver light or not when I would expect, so that part of system control seesm to be working.

Boiler is an old Ideal WLx RS50:

Old Honeywell ST7100 CH & HW contoller wiring:

Tado wireless receiver wiring:

Tado devices as listed on website (wireless receiver not connected as power was off):

I must have made a mistake somewhere but I can't see it. Any ideas?


  • No ideas anyone? Hot water control seems OK - when turned on (manually via app or scheduled) the 3-way value in the system operates to divert hot water to the cylinder. So I think my problem is just the CH being permanently on unless I kill the power to everything.

  • Sounds like you might have bridged the CH connections in the boiler, or that the CH relay in the wireless receiver is stuck. Can you hear it click?
  • There is a click when the LED on the wireless receiver lights to say that CH has been called for.

  • Check the y valve again, make sure it can move freely. Check that the wireless receiver is set to s and y plan (section 6) and try the test buttons.

    If none of that works check the config on the thermostat is set for relay and hot water (section 5).
  • Hi all , I have the same issue. CH is on permanently even when the indicator is not illuminated on the wireless receiver? I have checked the settings mentioned above also. Can anyone help please ? Thanks
  • Wiring issues are the most likely explanation for CH staying on, but I have previously seen reports of sticky relays keeping the heating on. Resolved by giving the receiver a not too hard tap.

  • HI All,

    Update on this for anyone interested.

    I checked the y-valve (working fine) and the config on the thermostat (all correct). Thanks for the helpful suggestions @johnnyp78. I'd also tried tapping it as hard as I dared in various directions in case of sticky relays.

    I contacted Tado support via the online messageing and went through a range of tests (slowly as each iteration took 2-3 days because of the use of messaging) and they eventually concluded that there was nothing more that could be tried and agreed a warranty replacement.

    I fitted the replacement wireless receiver yesterday afternoon and so far it is working fine. CH and HW are switching on and off when commanded. Sending the old unit back to Tado today.

    So there was something wrong with the wireless receiver that could not be diagnosed or corrected remotely.