One of my 4 trv is running at 27 even when off

One of my 4 trv is running at 27 even when off On the app and on the physical trv but still reads 27 and I can’t stop it bellowing out! Anyone help? No answer still from tado to my question

Answers

  • i have the same issue in my Dining room -> Thermostat displays as "OFF" but the heating is nerverending. and the Dinign area is heated upto 29degrees when i came home and the App & the Device continues to display "OFF" -> even after manually chnaging to some value and reverting to OFF doesnt do any trick to stop the heating.

  • Did you get any feedback from tado themselves?
  • I have the same problem. My bedroom radiator is piping hot and will not stop even though I have turned it off manually and through the app
  • Morning - tado answered and reset the parameters 24hrs ago so I am just monitoring it to see if it has worked over the next few days. I will report back 👍🏼
  • Thanks. I think I have sorted it. I deleted the valve and reinstalled it. So far so good
  • @AidanLangley : I did the same and now all TRVs are working perfectly - measured temperater at target-spot and also adjusted the Offset to set realistic temperatures. looks like Tado observed the new "correct" behaviour of my TRV and perhaps thus never answered :)

  • Mnag1234 - mine has levelled out and seems a lot better. But I have noticed my trv is always 1-1.3* higher than our pretty accurate baby temp
    Monitor in the room - how did you go about sorting yours if you don’t mind bud? Nice one
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!